Forum: FusionForge 5.0.2 released

Posted by: Alain Peyrat
Date: 2010-10-23 15:02
Summary: FusionForge 5.0.2 released
Project: FusionForge

Content:

Maintenance release, only bugfixes.
Monitor Forum | Start New Thread Start New Thread
RE: Am i the only one ? [ Reply ]
By: Nobody on 2011-07-11 09:02
[forum:398]
Installing from the debian.fusionforge repo i changed the password in the web ui and it fully works now, scm and all

RE: Am i the only one ? [ Reply ]
By: Thorsten Glaser on 2011-07-11 08:08
[forum:356]
(This would have maybe been better in the bugtracker)

I think you’re not supposed to work as user “admin”.

Instead, create another user (say fabrice), add him to the site admin group or (with RBAC) give him the site admin role – don’t know which of these two is correct in 5.0 – and then work as him.

I was unable to use svn as “admin” user too, but as normal user (with site admin privilegues) worked.

Am i the only one ? [ Reply ]
By: Fabrice Quenneville on 2011-07-10 03:00
[forum:355]
Ok so i have been trying to setup a working forge for our project for the past few days and i seem to be fiding all kinds of problems wich no-one has ever experienced or something.

to get my install working here are the steps i take:

apt-get install fusionforge-full
a2dissite default
service apache2 reload
newlist mailman
dpkg-reconfigure exim4-config
nano /etc/fusionforge/fusionforge.conf - where i put a proper name to our forge (Vanillux forge), and where i see that the password is empty and take following step)
/usr/sbin/fusionforge-config

from there i have tryed the following:
set a password in fusionforge.conf (web ui still will accept any password for the admin account, log-out/ back in will work with different password)
not set a password, leave it empty (web ui accept any password, log-out/ back in will work with different password)

i also created a few projects once (reinstalled since) after leaving 1 hr for the server to create the git repo's, anomscr will work but ssh+git will refuse any password entered.

so right now admin will accept any password and its driving me crazy, that from a debian stable install