Forum: help

Monitor Forum | Start New Thread Start New Thread
RE: Failed to install v6.03 on ubuntu16.04: multiple declare class Error in PHP [ Reply ]
By: Franck Villaume on 2016-05-11 18:02
[forum:919]
Ubuntu 16.04 ships PHP7.
You need to use latest FusionForge 6.0.4.
https://fusionforge.org/frs/?view=shownotes&group_id=6&release_id=46




Failed to install v6.03 on ubuntu16.04: multiple declare class Error in PHP [ Reply ]
By: Abel zhang on 2016-05-10 16:31
[forum:918]
Hi All:

I tried to install funsionforge v6.03 on ubuntu 16.04 with the following step:

sudo apt-get install fusionforge
.....

sudo forge_set_password admin xxxx

Then Error happends:

root@ubuntu:/home/gforgeadmin# forge_set_password admin gforgeadmin
PHP Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Error has a deprecated constructor in /usr/share/fusionforge/common/include/Error.class.php on line 36
PHP Fatal error: Cannot declare class Error, because the name is already in use in /usr/share/fusionforge/common/include/Error.class.php on line 36

After replaced "function Error()" with "function __construct() ", Try once more:

root@ubuntu:/home/gforgeadmin# forge_set_password admin gforgeadmin
PHP Fatal error: Cannot declare class Error, because the name is already in use in /usr/share/fusionforge/common/include/Error.class.php on line 36


How to fixed this issues? any ideas? thank you!