Forum: help

Monitor Forum | Start New Thread Start New Thread
RE: Plugin Authcas not synchronising Password [ Reply ]
By: Henri Massias on 2016-07-08 09:03
[forum:942]
Hi Franck,

Thank you for your quick answer.
Nice to know that sync_data_on is not used in the authcas plugin. It could be removed from the authcas config file.

AuthCAS & AuthLDAP are enabled simultaneously.
I send you the result of the SQL query by personal message.

I hope it will be enough for you to investigate. If not don't hesitate to ask me any information you need.

RE: Plugin Authcas not synchronising Password [ Reply ]
By: Franck Villaume on 2016-07-07 15:01
[forum:941]
Hi Henri,

sync_data_on is used by any enabled plugin which implements the hook sync_account_info.
authcas does not implement it. authldap does.
Therefore sync_data_on for authcas is ... useless.

Are your plugins AuthCAS & AuthLDAP enabled simultaneously?
Can you also provide the result of the SQL query: "select * from users where user_name = 'your CAS tested CAS login' before and after authldap test?




Plugin Authcas not synchronising Password [ Reply ]
By: Henri Massias on 2016-07-07 09:40
[forum:940]
Hello,
I have a problem with the authcas plugin.
I configured the authldap plugin which is working perfectly.

The authcas create an account and log on the web interface of fusionforge but the password synced in the database seems not to be OK i.e. git is not working (either via https or ssh).
If I try to log via Built-in authentication, it doesn't work.
If I log via authldap, it works and the password is then correctly synced. I can now use git and log in via built-in authentication.
Trying on more time with authcas, all works and the password does not change in the local database (no sync?).

sync_data_on = login is set for authcas and authldap.
I tried to look at the source files for authcas and authldap but for authcas I do not manage to see where the ldap synchronisation is called.

Does anyone else have the same issue (Tested on FusionForge 6.0.4 and Fusionforge 5.3.2)?
Does anyone have an idea on how to solve this issue?

Thank you.