[#330] [new mailman plugin] Breaks mailman

Description

Summary:

Detailed description

According to : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=638306#10 the new mailman plugin breaks stuff :

"Installing this plugin currently breaks Mailman, at least the version in Wheezy/Sid, and possibly even Squeeze. And I mean "breaks" as in "prevents the basic tools such as the one to create a new list from running", because it replaces (with dpkg diversions) part of the implementation of Mailman internals with a patched version based on an old version of Mailman. The newer Mailman has a different API, so its tools use it, but the implementation is still based the old one, with the old API. Bam, crash.

This needs to be fixed upstream. Preferably with a proper fix, and not a diversion of Mailman internals, otherwise we'll see the same problem at the next API change in Mailman."

This should be fixed if possible.

General Information
Submitted by:
Olivier Berger
Date Submitted: 2011-09-07 14:54
Last Modified by: Nobody
Last Modified: 2017-11-02 20:00
Permalink: https://fusionforge.org/tracker/a_follow.php/330
Actions
Internal Fields
Data Type: Feature requests
Assigned to: Nobody (None)
State: Open
Priority: 3
Extra Fields
Resolution:
none
Difficulty:
none
Target release:
none
Follow-up tabs
Message  ↓
Date: 2011-09-07 17:48
Sender: Alain Peyrat

Is it a debian specific problem or a fusionforge problem? Can you check and give the version of Mailman?

Date: 2011-09-07 14:58
Sender: Olivier Berger

Btw, there's apparently a PHP package related to mailman that could be of some help : http://pear.php.net/pepr/pepr-proposal-show.php?id=665 See also : http://sourceforge.net/projects/php-mailman/

No attached documents

No related commits.

No Changes Have Been Made to This Item

No relations found.