Home My Page Projects FusionForge
Summary Activity Forums Tracker Lists News SCM Files Mediawiki Hudson/Jenkins

[#746] Support MediaWiki newer than 1.19

Date:
2014-10-30 15:36
Priority:
3
State:
Closed
Submitted by:
Sylvain Beucler (beuc-inria)
Assigned to:
Franck Villaume (nerville)
Resolution:
Accepted
Difficulty:
Medium
Target release:
6.1
Summary:
Support MediaWiki newer than 1.19

Detailed description
Testing FusionForge 5.3.2 with MediaWiki 1.23 (more precisely the one from Fedora 20), apparently a few things need fixing like not including "Exceptions.php" which was removed, then I get a warning about deprecating skining and the layout is messed.

mira says: the skin probably needs to be rebased

Error: [512] A skin using autodiscovery mechanism, FusionForge, was found in your skins/ directory. The mechanism will be removed in MediaWiki 1.25 and the skin will no longer be recognized. See https://www.mediawiki.org/wiki/Manual:Skin_autodiscovery for information how to fix this. [Called from Skin::getSkinNames in /usr/share/mediawiki/includes/Skin.php at line 74] (/usr/share/mediawiki/includes/debug/Debug.php at 303)

I'm posting this item so we remember about this when we target a system with MediaWiki > 1.19 (which we currently support).
Message  ↓
Date: 2017-09-29 12:24
Sender: Franck Villaume

done.

Date: 2017-08-14 15:35
Sender: Franck Villaume

installation of mediawiki 1.27 now include.
Needs to be done:
- rewrite of the skin to support >= 1.25
- add new link for PSR
- review $user->saveSettings requirement.

Date: 2017-08-11 07:59
Sender: Franck Villaume

done for CentOS currently with Mediawiki 1.23
need to be ported to debian.
debian is providing mediawiki 1.27 in jessie-backport and stretch

Field Old Value Date By
status_idOpen2017-09-29 12:24nerville
close_dateNone2017-09-29 12:24nerville
DifficultySimple2017-08-14 15:35nerville
assigned_tonone2017-08-11 07:59nerville
ResolutionNone2017-08-11 07:59nerville
DifficultyNone2017-08-11 07:59nerville
Target releaseNone2017-08-11 07:59nerville
summarysupport MediaWiki than 1.192014-10-30 15:37beuc-inria