Forum: FusionForge 4.8 released

Posted by: Alain Peyrat
Date: 2009-06-17 19:28
Summary: FusionForge 4.8 released
Project: FusionForge


Major changes in 4.8:
* New classification by tags (aka tag cloud)
* New reporting page on frs to view the downloads per package
* List of all projects added in 'Project List'
* New version of wiki plugin (phpwiki), using lastest svn code
* Lots of translations improved.
Monitor Forum | Start New Thread Start New Thread
FusionForge 4.8 Questions [ Reply ]
By: Rob Dora on 2009-09-11 14:38
Hello, I have recently started using FusionForge (as of the 4.8 release). I’ve had some issues thus far that I have been unable to resolve. I’m not sure where I’m supposed to post this, so if there’s a better place, please let me know. (I found help forums forum_id 4 and 11 and discussion ones at 5 and 12, but there didn't seem to be anyone on them)
I originally downloaded the VMware Image to quickly check things out. I liked the project as a whole, but found some errors in the database format in the image (seemed like some code had been updated but the DB hadn't). For example, if I tried to submit a document, I would get an error saying that the column data_words didn’t exist in the table doc_data. I manually added the column and that fixed that. I encountered other problems that didn’t return errors cleanly, however, so I was unable to fix them, such as attempting to post a file in the forums.
I then downloaded the latest version of Centos and the latest Centos tarball. Everything was cleanly installed following the instructions exactly. In there, the document posting worked fine, but I encountered some other issues. Some of which I have solved, others which I haven’t been able to:
• Using the phpWiki: I was able to get the wiki setup fine and added to the project, but when I go to the Wiki, a fatal error is returned on the home page that says:
“lib/WikiDB/backend/PearDB.php:1111 Error: WikiDB_backend_PearDB_pgsql: fatal database error
DB Error: unknown error
(SELECT id FROM plugin_wiki_page WHERE pagename=’_g8_CategoryActionPage’ [nativecode=ERROR: current transaction is aborted, commands ignored until end of transaction block])”
That error appears twice and appears again if you try to create a page. I have run the query in psql and it returns the appropriate value. I have also had it print out all the variables its using and they all look fine.
I checked the error handler and found that if I make it always return (basically always assume it’s a false error), then things load up. You are able to edit every page, except the homepage, though creating new pages does not work (I have made sure that database user it’s using has all of the appropriate permissions). The edited pages are successfully stored in the database. If a person returns to the homepage, however, all of the pages are reset.
• No Summary Page appears for any project: If you click the summary link you get a 404 message. This worked in the VM and I haven’t been able to figure out what the difference is that’s causing this. This is true for the master project as well, right from the install. By going in as a project admin, you can see all the other pages and they work fine.
• Maximum Document Size: I was able to upload a variety of documents, but failed to upload a 10 MB pdf. The only difference between this and the other files was the size. I’ve encountered issues like this before where it’s just a php setting somewhere that restricts the upload size, so that might be it. When this document fails to upload, however, there is no error message, the page just refreshes.
• Accessing subversion: I was able to create an SCMSVN repository fine. I used svnadmin to copy over an old repository and I can access it by clicking Browse Subversion Tree. If I try to do a checkout, however, I get 405 method not allowed.
• File release system: This error, I was able to resolve. When I tried to upload a release, I would get an error saying that the file couldn’t be moved to the permanent directory /var/…/uploads//projectname, so I went through and printed out the messages and found that the issue was occurring in FRSFile->create(). I went into the /opt/gforge/common/frs/FRSFile.class.php and removed the extra / between upload directory and project name. This fixed the path that showed up in the error message, so next I had to go to the uploads directory and give apache ownership and write permissions. From there, file releases worked fine. You could, of course, also go further and remove a / on the end of the upload directory if you find where that’s being created.

Everything else I’ve looked at on FusionForge seems to be working really well and I like the additions that have built upon the original SourceForge system. My company might be interested in adopting this system, so it’s important for me to be able to get these issues resolved if that is to happen. Any help or advice that anyone can provide would be much appreciated.

Thank you,
Rob Dora