Forum: helpMonitor Forum | Start New Thread
By: Franck Villaume on 2017-08-07 09:04
unfortunately, FusionForge 6.x requires debian 8.
The detailled requirement is the support of AssignUserIDExpr, AssignGroupIDExpr in Apache ITK module which requires Apache httpd 2.4.7 or higher.
Apache httpd >= 2.4.7 is available in debian 8.
You can look at some backport for debian 7 but you are going to have a hard migration path.
Several forum threads already cover 5.x.x to 6.x migration.
Take a look at https://fusionforge.org/forum/forum.php?thread_id=476&forum_id=5&group_id=6
By: Brad Schoonover on 2017-08-02 19:02
|I did try installing 6.0.x onto my server, and I guess that folder got missed when I was doing a restart because I was recieving php errors when running the install script from the db.sh, and then again when I installed it from a git repo. Thank you for the heads up on the plugins. I also may have been running the wrong script. Do you know the best way to go about going from 5.3.4 to 6.0.x? Would it be easier to stay on debian 7 instead of going to debian 8? Thank you for the responses|
By: Franck Villaume on 2017-08-02 09:10
Thank you for these information.
About VERSION file:
The 5.3.4 tar.bz2 archive does not include such file and the install scripts do not generate such file.
However the 6.0.x does provide a VERSION file. Did you try to install a 6.0.x version?
About the plugins:
With debian 8, I'm not sure that mediawiki plugin will work correctly. Correct me if I'm wrong.
If you want to use 6.0.x version, you need to know that scmarch, scmbzr, scmdarcs have not been tested. scmhg is broken with 6.0.x but a partial fix is available in master.
By: Brad Schoonover on 2017-08-01 18:06
The current installation is running with 5.2.3 that was also installed with a tar file
I am using the blocks compactpreview hudson mediawiki oslc scmarch scmbzr scmcvs scmdarcs scmgit scmhg scmsvn plugins
It was installed using the install script
It is on debian 7
The new server has debian 8 on it with 5.3.4
By: Franck Villaume on 2017-08-01 05:26
Could you point me which tar file you used?
Can you describe your current 5.2.3 installation (which features, plugins are you using) ? how did you install it? which OS?
6.0.x requires CentOS 7 or debian 8. Did you update your OS too?
By: Brad Schoonover on 2017-07-31 23:07
I have been working on updating my ff server to a new one
I started at 5.2.3 and upgraded to 5.3.4 using the tar file, and ran the internal upgrade script, and I have a VERSION text file that says the version I am running is 6.0.3, but my website says 5.3.4. I also installed this on a new machine, and dump the information into a new psql table.