[#485] issues with webanalytics plugin

Description

Summary:

Detailed description

We came across a few issues with the webanalytics plugin :

  1. src/plugins/webanalytics/db/webanalytics-init.sql is missing the field "code", yet the field is referenced in src/plugins/webanalytics/common/webanalyticsPlugin.class.php

Installing webanalytics on a fresh new trunk fusionforge gives you an SQL error that the "code" field does not exist in the database.

  1. New feature request: There should be a possibility to edit / update existing analytics entries.

  2. Please use htmlspecialchar() to escape name and url in the list of available links. It should be possible to use ">" and "<" characters without breaking the HTML of the page.

General Information
Submitted by:
Marcel Baur
Date Submitted: 2012-07-26 11:06
Last Modified by: Nobody
Last Modified: 2017-11-02 20:00
Date Closed: 2012-08-16 13:38
Permalink: https://fusionforge.org/tracker/a_follow.php/485
Actions
Internal Fields
Data Type: Feature requests
Assigned to: Franck Villaume (nerville)
State: Closed
Priority: 3
Extra Fields
Resolution:
Accepted
Difficulty:
Simple
Target release:
5.3
Follow-up tabs
Message  ↓
Date: 2012-08-16 13:38
Sender: Franck Villaume

remark 2: implemented in trunk r16091

Date: 2012-08-16 11:31
Sender: Franck Villaume

Remark 3: seems to be related to headermenu plugin.

Date: 2012-07-29 11:05
Sender: Franck Villaume

missing db column has been fixed in trunk. r16040

No attached documents

No related commits.

Field Old Value Date By
DifficultyNone2012-08-16 13:38
Franck Villaume
Target releaseNone2012-08-16 13:38
Franck Villaume
status_idOpen2012-08-16 13:38
Franck Villaume
close_dateNone2012-08-16 13:38
Franck Villaume
assigned_tonone2012-08-16 13:38
Franck Villaume
ResolutionNone2012-08-16 13:38
Franck Villaume

No relations found.