[#821] scmsvn activity stalls



Detailed description

Hello, after migration from 5.3.4 to 6.0.4 we found a problem with svn projects. When we select the activity log the system stalls forever.

We tried several possibilities, but it always leads to infinite timeouts. The curl request in SVNPlugin.class.php - activity never returned until we stopped the apache server.

When i tried the request directly from a browser the request works, so it is proofed that the server configuration can answer a request correctly (for this i had to disable the session check). But even with disabled session check it doesn't work from inside the application.

I'm happily willing to hunt down this problem but currently i have no more clues what else i can do.


General Information
Submitted by:
Peter Katzmann
Date Submitted: 2016-07-20 12:35
Last Modified by: Nobody
Last Modified: 2017-11-02 20:00
Permalink: https://fusionforge.org/tracker/a_follow.php/821
Internal Fields
Data Type: Bugs
Assigned to: Nobody (None)
State: Open
Priority: 3
Extra Fields
Target Release:
Found in Version:
Follow-up tabs
Message  ↓
Date: 2016-07-25 11:05
Sender: Peter Katzmann

Linux gforge 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 GNU/Linux

Debian jessie + jessie-backports

It's all running inside an ESX Server.

We checked this curl parameters forth and back and seems to be valid. When we used the parameter string manually it works.

When i set a timeout as an option curl always runs into the timeout.

It's very strange and it is above my php knowledge to find a clue to debug this.

Date: 2016-07-23 13:07
Sender: Franck Villaume


can you provide more information about the version of your Linux system? I've just backport a fix from master with CentOS + cURL and viewvc.

Can you check the options in the code: curlsetopt($ch, CURLOPTWRITEFUNCTION, ...

curl debugging is really tricky.

No attached documents

No related commits.

No changes have been made to this item

No relations found.