[#876] Multiple Problems with the integration of Mediawiki 1.27



Detailed description

Hi Franck,

this integration creates a lot of issues here: - no wiki editor is working (tried: WYSIWYG, WikiEditor, VisualEdior); other extensions seem to work - all wiki settings are gray and can not be edited - search does not work - unable to move pages - missing images in Wiki pages (I as an admin can see them, but the user cannot see the images)

Did you already tested this with 6.1 and should this work or did I maybe encouter a bug with the wiki upgrades from 1.19 to 1.27?

Regards, Michael

General Information
Submitted by:
Michael Kluge
Date Submitted: 2018-01-24 15:19
Last Modified by:
Franck Villaume
Last Modified: 2018-09-28 14:29
Permalink: https://fusionforge.org/tracker/a_follow.php/876
Internal Fields
Data Type: Bugs
Assigned to: Nobody (None)
State: Open
Priority: 3
Extra Fields
Accepted As Bug
Target Release:
Found in Version:
Follow-up tabs
Message  ↓
Date: 2018-09-28 14:29
Sender: Franck Villaume

looks like a mediawiki debian package bug?

Date: 2018-09-21 13:19
Sender: Grégory Rocher

Hi both I'm currently preparing a migration of a fusionforge with mediawiki 1.27 I can reproduce the bug with le WikiEditor toolbar

It's packaged with WikiEditor : /usr/share/mediawiki/extensions-core/WikiEditor/ And loaded in fusionforge-plugin-mediawiki > grep WikiEditor /usr/share/fusionforge/plugins/mediawiki/www/LocalSettings.php > wfLoadExtension( 'WikiEditor' );

But I see the error wen I edit pages > ... LessExceptionParser from line 2616 of /usr/share/mediawiki/vendor/oyejorge/less.php/lib/Less/Parser.php: File mediawiki.mixins not found ...

I think I found a workaround mediawiki.mixins is in the (src-)package > dpkg -L mediawiki|grep mediawiki.mixins.less > /usr/share/mediawiki/resources/src/mediawiki.less/mediawiki.mixins.less

And when you copy the mediawiki.mixins.less file in /usr/share/mediawiki/extensions-core/WikiEditor/modules/ > cp /usr/share/mediawiki/resources/src/mediawiki.less/mediawiki.mixins.less /usr/share/mediawiki/extensions-core/WikiEditor/modules/

The editor works again

There must be a cleaner way to do it ? with $wgResourceLoaderLESSImportPaths ? But it's deprecated...

Date: 2018-06-12 10:02
Sender: Michael Kluge

Hi Franck,

I just tried to enable any of the Wiki WYSIWG editors. All do not show up on the wiki pages. The "edit" tab shows up for a second an then goes away. Testet with todays head and a fresh debian 9. There is nothing in the logs.

Regards, Michael

Date: 2018-03-30 10:14
Sender: Franck Villaume


any update on this topic?

I've looked at debian mediawiki. I can reproduce the default toolbar not showing. I activate the default "MonoBook" skin and I get the same error:

[5049c67d4e8197db1e6452d5] /plugins/mediawiki/wiki/demoproject/load.php?debug=false&lang=us&modules=jquery.accessKeyLabel%2CbyteLength%2CbyteLimit%2Cclient%2CtextSelection%7Cmediawiki.RegExp%2Cnotify%2Ctoolbar%2Cutil%7Cmediawiki.action.edit%7Cmediawiki.action.edit.styles%7Cmediawiki.page.startup&skin=monobook&version=223d7b2023cf LessExceptionParser from line 2616 of /usr/share/mediawiki/vendor/oyejorge/less.php/lib/Less/Parser.php: File mediawiki.mixins not found. in toolbar.less load.php:4:39 [d4e77c90757ecc8765fb9d77] /plugins/mediawiki/wiki/demoproject/load.php?debug=false&lang=us&modules=jquery.checkboxShiftClick%2Ccookie%2CgetAttrs%2ChighlightText%2CmakeCollapsible%2Cmw-jump%2Cplaceholder%2Csuggestions%7Cmediawiki.action.edit.collapsibleFooter%2CeditWarning%2Cstash%7Cmediawiki.api%2Ccldr%2CconfirmCloseWindow%2Ccookie%2Cicon%2CjqueryMsg%2Clanguage%2CsearchSuggest%2Cuser%7Cmediawiki.api.user%7Cmediawiki.language.data%2Cinit%7Cmediawiki.libs.pluralruleparser%7Cmediawiki.page.ready%7Csite%7Cuser.defaults&skin=monobook&version=36810fcfdba1 LessExceptionParser from line 2616 of /usr/share/mediawiki/vendor/oyejorge/less.php/lib/Less/Parser.php: File mediawiki.mixins not found. in mediawiki.icon.less

Can you check on your side? To use the default MonoBook skin, you have to modify the LocalSettings.php provided by FusionForge.

Date: 2018-01-25 05:53
Sender: Michael Kluge

Yes, moving works for me too now. It was actually missing one of the libs that you habe to install with composer.

Date: 2018-01-24 19:33
Sender: Franck Villaume

  • moving page: that works. Can you share more insight?

Date: 2018-01-24 19:30
Sender: Franck Villaume

partial fix is available for user preference: see commit: 29c7812d37c7eed86a43611d251b8f529be18f6b

Date: 2018-01-24 19:00
Sender: Franck Villaume

Hi Michael,

FusionForge is running Jessie + FusionForge 6.1 + MW 1.27. - Search is working. nothing to do here. - I do remember some issues with the images. I had to edit the page and save it again. Sounds like a MW bug. - wysiwig: fusionforge is not using any. I will look into it. - wiki settings: same as you, everything is gray. I will look into it.

No attached documents

No related commits.

Field Old Value Date By
ResolutionNone2018-01-24 19:05
Franck Villaume

No relations found.