[#922] Database fixes for postgresql 12

Description

Summary:

Detailed description

Since postgresql version 12 the sql statement 'with oids' is no longer supported (https://www.postgresql.org/docs/12/sql-createtable.html), which causes the installation of the fusionforge database to fail.

The appended patch fixes this issue.

General Information
Submitted by:
Ralf Habacker
Date Submitted: 2021-03-09 09:28
Last Modified by:
Franck Villaume
Last Modified: 2021-04-16 12:33
Date Closed: 2021-04-16 12:33
Permalink: https://fusionforge.org/tracker/a_follow.php/922
Actions
Internal Fields
Data Type: Patches
Assigned to: Franck Villaume (nerville)
State: Closed
Priority: 3
Extra Fields
Base branch:
6.1
Resolution:
Accepted
Follow-up tabs
Message  ↓
Date: 2021-04-16 12:33
Sender: Franck Villaume

Merged into 6.1

Attachments:
Size Name Date By Download
2 KiB0001-src-db-Remove-usage-of-with-oids-required-for-postgr.patch2021-03-09 09:28
Ralf Habacker
0001-src-db-Remove-usage-of-with-oids-required-for-postgr.patch

No related commits.

Field Old Value Date By
status_idOpen2021-04-16 12:33
Franck Villaume
close_dateNone2021-04-16 12:33
Franck Villaume
assigned_tonone2021-03-22 18:02
Franck Villaume
ResolutionNone2021-03-22 18:02
Franck Villaume
File Added540: 0001-src-db-Remove-usage-of-with-oids-required-for-postgr.patch2021-03-09 09:28
Ralf Habacker

No relations found.